It appears that your browser does not support JavaScript. We use JavaScript on our website to display some information. Please use a browser that supports JavaScript.

D2L Technical Requirements

Browser support

D2L is committed to performing key application testing when new browser versions are released. However, due to the frequency of some browser releases, D2L cannot guarantee that each browser version will perform as expected.

Supported browsers are the latest or most recent browser versions that are tested against new versions of D2L products. Customers can report problems and receive support for issues. For an optimal experience, D2L recommends using supported browsers with D2L products.

Maintenance browsers are older browser versions that are not tested extensively against new versions of D2L products. Customers can still report problems and receive support for critical issues; however, D2L does not guarantee all issues will be addressed. A maintenance browser becomes officially unsupported after one year.

Note the following:

  • Ensure that your browser has JavaScript and Cookies enabled.
  • For desktop systems, you must have Adobe Flash Player 10.1 or greater.

Do a System Check to ensure your system is configured properly.



Desktop Support

Browser

Supported Browser Version(s)

Maintenance Browser Version(s)

Microsoft® Edge

Latest

n/a

Microsoft® Internet Explorer®

n/a

11

Mozilla® Firefox®

Latest, ESR

n/a

Google® Chrome™

Latest

n/a

Apple® Safari®

Latest

n/a



Tablet and Mobile Support

Device

Operating System

Browser

Supported Browser Version(s)

Android™

Android 4.4+

Android

Latest

Apple

iOS® 6, 7, 8, 9, and 10

Safari

Latest

Microsoft Surface™

Windows® 8

Internet Explorer

11

BlackBerry® (mobile only)

BlackBerry 7, 10

BlackBerry



If you still have problems with your online courses, please submit a problem report, and we'll help.